僕Drive

記憶なんて曖昧なものだから、もっとハードなものに記録します

PHP7.x系とPHP5.x系の差

Wordpressで出てくる、選択肢としてPHPのバージョンがある。
その他にもCGI版かモジュール版かという話もあるが、今回はおいておこう。
先に言っておくと、PHP6.x系というのは存在しない。こういうのもITの世界ではよくある話ではある。iPhone9が無かったり。

んでどっちが良いの?

さて、バージョン7系統と5系統選べるのであれば、断然7系統をお勧めする。赤くはないが、一般的に5系統より処理速度が3倍速いといわれている。 セキュリティ的にも、7系統の方が安全。
なぜ、では5系統が残っているのか。このあたり、Wordpress利用者にはあまり関係ないが、pearが厳密には組み込まれなくなったとか、裏事情がある。Pagerが使えないとかMailが使えないとか。